Description:

Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List that starts at the specified index and contains the specified number of elements.

Syntax:
public int IndexOf(
T item,
int index,
int count
)
Parameters:
  • item
  • Type: T
  • The object to locate in the List. The value can be a None reference (Nothing in Visual Basic) for reference types.
  • index
  • Type: int
  • The zero-based starting index of the search.
  • count
  • Type: int
  • The number of elements in the section to search.
Returns:
Type: int
The zero-based index of the first occurrence of item within the entire List, if found; otherwise, -1.

Description:

Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List that extends from the specified index to the last element.

Syntax:
public int IndexOf(
T item,
int index
)
Parameters:
  • item
  • Type: T
  • The object to locate in the List. The value can be a None reference (Nothing in Visual Basic) for reference types.
  • index
  • Type: int
  • The zero-based starting index of the search.
Returns:
Type: int
The zero-based index of the first occurrence of item within the entire List, if found; otherwise, -1.

Description:

Searches for the specified object and returns the zero-based index of the first occurrence within the entire List.

Syntax:
public int IndexOf(
T item
)
Parameters:
  • item
  • Type: T
  • The object to locate in the List. The value can be a None reference (Nothing in Visual Basic) for reference types.
Returns:
Type: int
The zero-based index of the first occurrence of item within the entire List, if found; otherwise, -1.

Nothing found